Вход на сайт

МЕДИАМЕТРИКА

Облако тегов

Вирус Kaptoxa с русскими «корнями» похитил данные миллионов американцев

Аватар пользователя Partisan

Кибервзломщики атаковали крупную американскую торговую сеть Target. При помощи вируса Kaptoxa были похищены персональные данные 70 миллионов клиентов, совершивших покупки в период рождественских и новогодних распродаж.

Эксперты в области компьютерной безопасности провели свое расследование, итоги которого были разосланы рителерам США. Указывается, что Kaptoxa частично был написан на русском языке.

Скорее всего, отмечает ИТАР-ТАСС, по-русски были написаны комментарии к вирусу. Также известно, что Kaptoxa появился на рынке хакеров весной 2013-го.

Эксперты отметили, что вороватая программе была инновационной, она свидетельствует о высоком уровне мастерства ее создателей. Антивирусы, которые используют для защиты американские ритейлеры, перед Kaptoxa не устояли.

http://www.ntv.ru/novosti/831302/

Инновации, чо...

Фонд поддержки авторов AfterShock

Комментарии

Аватар пользователя Evg_Ban
Evg_Ban(5 лет 3 месяца)(07:57:17 / 17-01-2014)

Указывается, что Kaptoxa частично был написан на русском языке.

Это как? коментарии к коду? Или:

?

Аватар пользователя htower
htower(5 лет 10 месяцев)(08:01:40 / 17-01-2014)

Видимо, это был код на языке 1С - эта система как раз с финансами работает :)

Что-то вроде такого:

Функция глОстатокVB(тов) Экспорт
Перем знТов;
КодТовара=СокрЛП(тов);
знТов=0;
Если СтрДлина(КодТовара)>0 Тогда
спрТов=СоздатьОбъект("Справочник.Товары");
Если СтрДлина(КодТовара)<Метаданные.Справочник("Товары").ДлинаКода Тогда
СчетчикЦикла = Метаданные.Справочник("Товары").ДлинаКода-СтрДлина(КодТовара);
Для к=1 По СчетчикЦикла Цикл
КодТовара=" "+КодТовара;
КонецЦикла;
СчетчикЦикла = "";
КонецЕсли;
Если спрТов.НайтиПоКоду(КодТовара,0)>0 Тогда
Товар=спрТов.ТекущийЭлемент();
знТов=Регистр.ОстаткиТоваров.СводныйОстаток(Товар,,,"ОстатокТовара");
Товар="";
КонецЕсли;
спрТов="";
КонецЕсли;
Возврат знТов;
КонецФункции

Аватар пользователя Evg_Ban
Evg_Ban(5 лет 3 месяца)(08:07:14 / 17-01-2014)

О, не пришло в голову. Но тогда выходит, что они там однасуку юзают? Странно.

Аватар пользователя htower
htower(5 лет 10 месяцев)(08:08:29 / 17-01-2014)

Да стеб это :)

Аватар пользователя Evg_Ban
Evg_Ban(5 лет 3 месяца)(08:18:46 / 17-01-2014)

Ну в Германии 1с уже присутствует, так что хз. http://1c-germany.com/de/

Аватар пользователя Dvorkin
Dvorkin(5 лет 10 месяцев)(08:22:34 / 17-01-2014)

... а написал его Антоха.

диагностические сообщения типа printf там наверное на русском есть

Аватар пользователя Igoris
Igoris(4 года 3 дня)(08:24:05 / 17-01-2014)

Я даже догадываюсь, какие там русские слова есть

Аватар пользователя Dvorkin
Dvorkin(5 лет 10 месяцев)(09:26:50 / 17-01-2014)

я уверен, талантливый Антоха талантлив во всем и смог ввести в код программы такие слова, которые не то что на заборах на встретить, но и связьнадзор-то никогда не публиковал в своем списке запрещенных сайтов

Аватар пользователя Пешеход
Пешеход(4 года 7 месяцев)(08:57:55 / 17-01-2014)

ждём balalayka и leninh&stalin

Аватар пользователя Igoris
Igoris(4 года 3 дня)(09:02:00 / 17-01-2014)

И   vodka-medved'  !

Аватар пользователя Dvorkin
Dvorkin(5 лет 10 месяцев)(09:23:35 / 17-01-2014)

пиком паранойи, надо полагать станет момент, когда прогоняя вирус дебаггером начальник американского филиала лаборатории Касперского, обнаружив в коде программы оператор put in, выбросится из окна с криком "русские идут!"

Аватар пользователя ko_mon
ko_mon(5 лет 9 месяцев)(13:09:20 / 17-01-2014)

+!

Аватар пользователя serghey
serghey(5 лет 11 месяцев)(17:28:31 / 17-01-2014)

Вот Вы смеетесь, а для англицированного уха, и не впервую очередь для программеров, фамилия Путин очень говорящая: Put in - вкалывать! и много чего еще, см. словарь

Аватар пользователя Dvorkin
Dvorkin(5 лет 10 месяцев)(17:31:41 / 17-01-2014)

мне нравится вариант "предьявлять"

Аватар пользователя Руслан
Руслан(5 лет 3 недели)(09:32:29 / 17-01-2014)

Не каптоха, а картоха.

Аватар пользователя Аббе
Аббе(4 года 4 месяца)(09:49:21 / 17-01-2014)

То есть, когда мои предпочтения собираются браузером БЕЗ МОЕГО СОГЛАСИЯ - это демократично, а Картоха - совсем даже нет? Ребята, Вы бы уже как то определилсь, или трусы, или крестик. Штука в том, что учатся то У ВАС. И не всегда напрямую. Помнят про Иран-Контрас, про 10% Ваших мерзостей для ВСЕГО мира, и учатся ЭТОМУ. Почему про 10%? Да потому, что ВСЕ мерзости, что сделаны хозяевами США миру помнить не может уже никто. Разве что Господь Бог закажет жёсткие диски на тераГИГАтерабайты информации.
В сияющих США обитателей планеты за людей не считают. Увы, обитатели планеты жителей США считают не более, как людоедами. 
Так что - или трусы, или крестик. И не забудьте отчитаться за планирование проведение в интетерсах США и ВМВ и кучи иных мерзостей. Пока не отчитатетесь - ВСЕ мерзости мира числятся произведеёнными в США.
Приятного Вам аппетита! 

Аватар пользователя PavelCV
PavelCV(5 лет 1 месяц)(11:55:17 / 17-01-2014)
Большой плюс!
Аватар пользователя ko_mon
ko_mon(5 лет 9 месяцев)(00:47:58 / 18-01-2014)

Указывается, что Kaptoxa частично был написан на русском языке.

... и с ярлычком "Made in Russia", ога. КроваваяРукатм и всё такое. 

 

Аватар пользователя kokunov
kokunov(5 лет 9 месяцев)(20:05:58 / 17-01-2014)

Летс ми спик фром май харт

Аватар пользователя Мэкс
Мэкс(5 лет 8 месяцев)(00:48:20 / 18-01-2014)

А никто не мешает называть переменные простыми русскими словами:

medved, balalayka, vodka, kvas, borsch

в результате получались конструкции типа:

if medved.balalayka then 

   borsch = kvas

else

   borsch=vodka

end if

Лидеры обсуждений

за 4 часаза суткиза неделю

Лидеры просмотров

за неделюза месяцза год

СМИ

Загрузка...